System Slowness

Incident Report for CourseArc

Monitoring

Performance is looking much better now. We will continue to monitor and adjust as needed.
Posted Aug 25, 2025 - 14:36 UTC

Investigating

We are seeing some system slowness. Systems are scaling up and should speed up shortly.
Posted Aug 25, 2025 - 14:14 UTC
This incident affects: Application.